create MethodStatic
Create a DefinitionGroup
create(iModelDb: IModelDb, definitionModelId: string, code: Code, isPrivate?: boolean): DefinitionGroup
@returns The newly constructed DefinitionGroup
@note There is not a predefined CodeSpec for DefinitionGroup elements, so it is the responsibility of the domain or application to create one.
@throws IModelError if there is a problem creating the DefinitionGroup
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | The IModelDb |
definitionModelId | string | The Id of the DefinitionModel that will contain this DefinitionGroup element. |
code | Code | The Code for this DefinitionGroup |
isPrivate | boolean | The optional hint, that if true means it should not be displayed in the UI. |
Returns - DefinitionGroup
The newly constructed DefinitionGroup
Defined in
- core/backend/src/Element.ts Line 1038
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.