ECEnumValue Interface
Deprecated in 4.11. Use IModelDb.createQueryReader or ECDb.createQueryReader to query.
For ECDb, use ECDb.withCachedWriteStatement or ECDb.withWriteStatement to Insert/Update/Delete. IModelDb.createQueryReader is an asynchronous API. If you encounter a use case that cannot be converted to async, please report an issue at https://github.com/iTwin/itwinjs-core/issues. Mean while use IModelDb.withPreparedStatement for synchronous API calls where conversion to async is not possible.
Represents the value of an ECEnumeration.
See also:
Properties
Name | Type | Description | |
---|---|---|---|
key | string | ||
name | string | ||
schema | string | ||
value | string | number |
Defined in
- core/backend/src/ECSqlStatement.ts Line 844
Last Updated: 17 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.