createQueryReader Method
Allow to execute query and read results along with meta data. The result are streamed.
See also:
createQueryReader(ecsql: string, params?: QueryBinder, config?: QueryOptions): ECSqlReader
@returns Returns an ECSqlReader which helps iterate over the result set and also give access to metadata.
Parameter | Type | Description |
---|---|---|
ecsql | string | |
params | QueryBinder | The values to bind to the parameters (if the ECSQL has any). |
config | QueryOptions | Allow to specify certain flags which control how query is executed. |
Returns - ECSqlReader
Returns an ECSqlReader which helps iterate over the result set and also give access to metadata.
Defined in
- core/backend/src/IModelDb.ts Line 474
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.