PropertyFilterBuilderActions Class
Actions for controlling PropertyFilterBuilder component state.
Methods
Name | Description | |
---|---|---|
constructor(setState: (setter: (prevState: PropertyFilterBuilderState) => PropertyFilterBuilderState) => void): PropertyFilterBuilderActions | ||
addItem(path: string[], item: PropertyFilterRule | PropertyFilterRuleGroup | "RULE_GROUP" | "RULE"): void | Adds new rule or group of rules to the group specified by path. | |
removeAllItems(): void | Removes all items from root group. | |
removeItem(path: string[], allowLastRuleDelete: booleanfalse): void | Removes item specified by path. | |
Sets error messages of the rules specified by id. | ||
setRuleGroupOperator(path: string[], operator: "and" | "or"): void | Sets operator of rule group specified by the path. | |
setRuleOperator(path: string[], operator: PropertyFilterBuilderRuleOperator): void | Sets operator of rule specified by the path. | |
setRuleProperty(path: string[], property?: PropertyDescription): void | Sets property of rule specified by the path. | |
setRuleValue(path: string[], value: PropertyValue): void | Sets value of rule specified by the path. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.