NumericInputEditor Class
NumericInputEditor React component that is a property editor with numeric input & up/down buttons
Extends
- React.PureComponent<PropertyEditorProps, NumericInputEditorState>
Implements
Methods
Name | Description | |
---|---|---|
componentDidMount(): void | ||
componentDidUpdate(prevProps: PropertyEditorProps): void | ||
componentWillUnmount(): void | ||
getPropertyValue(): Promise<undefined | PropertyValue> | ||
render(): React.ReactNode |
Properties
Name | Type | Description | |
---|---|---|---|
hasFocus | boolean | ||
htmlElement Accessor ReadOnly | "null" | HTMLElement | ||
state Readonly | Readonly<NumericInputEditorState> |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.