EnumEditor Class
EnumEditor React component that is a property editor with select input
Extends
- React.PureComponent<PropertyEditorProps, EnumEditorState>
Implements
Methods
Name | Description | |
---|---|---|
componentDidMount(): void | ||
componentDidUpdate(prevProps: PropertyEditorProps): void | ||
componentWillUnmount(): void | ||
getPropertyValue(): Promise<undefined | PropertyValue> | ||
render(): React.JSX.Element |
Properties
Name | Type | Description | |
---|---|---|---|
hasFocus Accessor ReadOnly | boolean | ||
htmlElement Accessor ReadOnly | "null" | HTMLElement | ||
state Readonly | Readonly<EnumEditorState> |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.