NavigationPropertyValueRenderer Class

Deprecated  in 4.14.0. Use PrimitivePropertyValueRenderer instead.

Default Navigation Property Renderer

Implements

Methods

Name Description
constructor(): NavigationPropertyValueRenderer    
canRender(record: PropertyRecord): boolean Checks if the renderer can handle given property  
render(record: PropertyRecord, context?: PropertyValueRendererContext): React.JSX.Element Method that returns a JSX representation of PropertyRecord  

Defined in

Last Updated: 14 November, 2024