ActionButton Interface
Describes the data needed to insert an action button into a toolbar.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
execute Readonly | () => void | function to run when the button is pressed. | |
icon Readonly | string | ConditionalStringValue | Name of icon WebFont entry or if specifying an imported SVG symbol use "webSvg:" prefix to imported symbol Id. | |
label Readonly | string | ConditionalStringValue | label, shown as tool tip on a button or an item label in a group. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
applicationData Readonly Inherited | any | undefined | ToolbarItem | can be used by application to store miscellaneous data. |
badgeType Readonly Inherited | BadgeType | undefined | ToolbarItem | Describes badge. |
description Readonly Inherited | string | ConditionalStringValue | ToolbarItem | Optional description |
groupPriority Readonly Inherited | number | undefined | ToolbarItem | Specifies the item's grouping value. |
id Readonly Inherited | string | ToolbarItem | Require uniqueId for the item. |
internalData Readonly Inherited | Map<string, any> | undefined | ToolbarItem | optional data to used by item implementor. |
isActive Readonly Inherited | boolean | undefined | ToolbarItem | Defines if the item is active (shown with an active stripe/bar). |
isDisabled Readonly Inherited | boolean | ConditionalBooleanValue | ToolbarItem | Describes if the item is enabled or disabled. |
isHidden Readonly Inherited | boolean | ConditionalBooleanValue | ToolbarItem | Describes if the item is visible or hidden. |
isPressed Readonly Inherited | boolean | undefined | ToolbarItem | Describes if the item should appear pressed (used for displaying toggle state). |
itemPriority Readonly Inherited | number | ToolbarItem | Priority within a toolbar or group. |
parentToolGroupId Readonly Inherited | string | undefined | ToolbarItem | Optional parent tool group to add tool. |
providerId Readonly Inherited | string | undefined | ToolbarItem | id of UiItemsProvider |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.