ConditionalBooleanValue Class
Class used to return a boolean value. The boolean value is refreshed by using the specified function. The syncEventIds define one or more eventIds that would require the testFunc to be rerun.
Methods
Name | Description | |
---|---|---|
constructor(testFunc: () => boolean, syncEventIds: string[], value?: boolean): ConditionalBooleanValue | Constructor for ConditionalBooleanValue. | |
refresh(): boolean | Called to update the value by running the testFunc | |
getValue(conditionalValue: boolean | ConditionalBooleanValue): boolean Static | helper function to get boolean from a ConditionalBooleanValue | boolean | undefined | |
refreshValue(conditionalValue: boolean | ConditionalBooleanValue, eventIds: Set<string>): boolean Static | helper function to process properties defined as type ConditionalBooleanValue | boolean | undefined |
Properties
Name | Type | Description | |
---|---|---|---|
syncEventIds Readonly | string[] | An array of eventId that should be monitored to determine when to run the refresh method. | |
testFunc Readonly | () => boolean | Function to run to retrieve the value for the conditional. | |
value Accessor ReadOnly | boolean | The current boolean value of the conditional. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.