ToolbarItem Interface
Describes the data needed to insert a UI items into an existing set of UI items.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
applicationData Readonly | any | undefined | can be used by application to store miscellaneous data. | |
badgeType Readonly | BadgeType | undefined | Describes badge. | |
description Readonly | string | ConditionalStringValue | Optional description | |
groupPriority Readonly | number | undefined | Specifies the item's grouping value. | |
id Readonly | string | Require uniqueId for the item. | |
internalData Readonly | Map<string, any> | undefined | optional data to used by item implementor. | |
isActive Readonly | boolean | undefined | Defines if the item is active (shown with an active stripe/bar). | |
isDisabled Readonly | boolean | ConditionalBooleanValue | Describes if the item is enabled or disabled. | |
isHidden Readonly | boolean | ConditionalBooleanValue | Describes if the item is visible or hidden. | |
isPressed Readonly | boolean | undefined | Describes if the item should appear pressed (used for displaying toggle state). | |
itemPriority Readonly | number | Priority within a toolbar or group. | |
parentToolGroupId Readonly | string | undefined | Optional parent tool group to add tool. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
providerId Readonly Inherited | string | undefined | ProvidedItem | id of UiItemsProvider |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.