AbstractMenuItemProps Interface
Properties for a Menu item
Extends
Properties
Name | Type | Description | |
---|---|---|---|
iconRight | string | ConditionalStringValue | Icon to display on right side of the menu item. | |
id | string | The id for the menu item. | |
item | AbstractActionItemProps | undefined | The item to execute when this item is invoked. | |
submenu | AbstractMenuItemProps[] | undefined | Nested array of item props. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
applicationData Inherited | any | undefined | CommonItemProps | can be used by application to store miscellaneous data. |
badgeType Inherited | BadgeType | undefined | CommonItemProps | Badge to be overlaid on the item. |
description Inherited | string | ConditionalStringValue | CommonItemProps | if set, it is used to explicitly set the description shown by components that support a description. |
icon Inherited | string | ConditionalStringValue | CommonItemProps | Name of icon WebFont entry or if specifying an imported SVG symbol use "webSvg:" prefix to imported symbol Id. |
internalData Readonly Inherited | Map<string, any> | undefined | CommonItemProps | optional data to be used by item implementor. |
isActive Inherited | boolean | undefined | CommonItemProps | if set, component will be considered "active" an will display an "active stripe" - defaults to false |
isDisabled Inherited | boolean | ConditionalBooleanValue | CommonItemProps | if true component will be disabled - defaults to false |
isHidden Inherited | boolean | ConditionalBooleanValue | CommonItemProps | if true component will be hidden - defaults to false |
isPressed Inherited | boolean | undefined | CommonItemProps | if set, component will be considered selected but will NOT display an "active stripe" - defaults to false. |
label Inherited | string | ConditionalStringValue | CommonItemProps | if set, it is used to explicitly set the label shown by a component. |
tooltip Inherited | string | ConditionalStringValue | CommonItemProps | used to explicitly set the tooltip shown by a component. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.