RootNodeRule Interface
Root node rules are used to define nodes that are displayed at the root hierarchy level.
@see Root node rule reference documentation page
Extends
Properties
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
condition Inherited | string | undefined | NavigationRuleBase | Defines a condition which needs to be met in order for the rule to be used. |
customizationRules Inherited | CustomizationRule[] | undefined | NavigationRuleBase | A list of customization rules that |
onlyIfNotHandled Inherited | boolean | undefined | NavigationRuleBase | Tells the library that the rule should only be handled if no other rule of the same type was handled previously (based on rule |
priority Inherited | number | undefined | NavigationRuleBase | Defines the order in which rules are handled, higher number means the rule is handled first. |
requiredSchemas Inherited | RequiredSchemaSpecification[] | undefined | NavigationRuleBase | A list of ECSchema requirements that need to be met for the rule to be used. |
specifications Inherited | ChildNodeSpecification[] | undefined | NavigationRuleBase | A list of hierarchy specifications that define what nodes are going to be returned. |
stopFurtherProcessing Inherited | boolean | undefined | NavigationRuleBase | Stop processing rules that have lower priority. |
subConditions Inherited | SubCondition[] | undefined | NavigationRuleBase | A list of sub-rules which share placement attributes and |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.