GroupingRule Interface
Grouping rules provide advanced ways to group instances when creating hierarchies.
@see Grouping rule reference documentation page
Extends
Properties
Name | Type | Description | |
---|---|---|---|
class | SingleSchemaClassSpecification | Specification of ECClass which should be grouped using this rule. | |
condition | string | undefined | An ECExpression that results in | |
groups | GroupingSpecification[] | Specifies a list of grouping specifications | |
ruleType | "Grouping" | Used for serializing to JSON. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
onlyIfNotHandled Inherited | boolean | undefined | RuleBase | Tells the library that the rule should only be handled if no other rule of the same type was handled previously (based on rule |
priority Inherited | number | undefined | RuleBase | Defines the order in which rules are handled, higher number means the rule is handled first. |
requiredSchemas Inherited | RequiredSchemaSpecification[] | undefined | RuleBase | A list of ECSchema requirements that need to be met for the rule to be used. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.