DefaultPropertyCategoryOverride Interface
A rule that allows overriding the default property category.
The default property category is a category that gets assigned to properties that otherwise have no category.
@see Default property category override reference documentation page
Extends
Properties
Name | Type | Description | |
---|---|---|---|
ruleType | "DefaultPropertyCategoryOverride" | Used for serializing to JSON. | |
specification | PropertyCategorySpecification | Specification for the custom property category. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
onlyIfNotHandled Inherited | boolean | undefined | RuleBase | Tells the library that the rule should only be handled if no other rule of the same type was handled previously (based on rule |
priority Inherited | number | undefined | RuleBase | Defines the order in which rules are handled, higher number means the rule is handled first. |
requiredSchemas Inherited | RequiredSchemaSpecification[] | undefined | RuleBase | A list of ECSchema requirements that need to be met for the rule to be used. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.