PresentationError Class

An error type thrown by Presentation APIs.

Extends

  • BentleyError

Methods

Name Description
constructor(errorNumber: PresentationStatus, message?: string, getMetaData?: GetMetaDataFunction): PresentationError Creates an instance of Error.  
_initName(): string Protected Returns the name of each error status.  

Inherited methods

Name Inherited from Description
BentleyError get the meta data associated with this BentleyError, if any.
getErrorMessage(error: unknown): string Static Inherited BentleyError Use run-time type checking to safely get a useful string summary of an unknown error value, or "" if none exists.
BentleyError Use run-time type checking to safely get the metadata with an unknown error value, if possible.
getErrorProps(error: unknown): ErrorProps Static Inherited BentleyError Returns a new ErrorProps object representing an unknown error value.
getErrorStack(error: unknown): undefined | string Static Inherited BentleyError Use run-time type checking to safely get the call stack of an unknown error value, if possible.
BentleyError get the metadata object associated with an ExceptionMetaData, if any.

Inherited properties

Name Type Inherited from Description
errorNumber Inherited number BentleyError  
boolean BentleyError Returns true if this BentleyError includes (optional) metadata.

Defined in

Last Updated: 14 November, 2024