HierarchyLevelDescriptorRequestOptions<TIModel, TNodeKey, TRulesetVariable> Interface
Params for hierarchy level descriptor requests.
Extends
- RequestOptionsWithRuleset<TIModel, TRulesetVariable>
Properties
Name | Type | Description | |
---|---|---|---|
parentKey | TNodeKey | undefined | Key of the parent node to get hierarchy level descriptor for. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
imodel Inherited | TIModel | RequestOptionsWithRuleset<TIModel, TRulesetVariable> | iModel to request data from |
locale Inherited | string | undefined | RequestOptionsWithRuleset<TIModel, TRulesetVariable> | Optional locale to use when formatting / localizing data |
rulesetOrId Inherited | string | Ruleset | RequestOptionsWithRuleset<TIModel, TRulesetVariable> | Ruleset or id of the ruleset to use when requesting data |
rulesetVariables Inherited | TRulesetVariable[] | undefined | RequestOptionsWithRuleset<TIModel, TRulesetVariable> | Ruleset variables to use when requesting data |
unitSystem Inherited | UnitSystemKey | undefined | RequestOptionsWithRuleset<TIModel, TRulesetVariable> | Unit system to use when formatting property values with units. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.