ContentInstanceKeysRequestOptions<TIModel, TKeySet, TRulesetVariable> Interface
Request type for content instance keys' requests.
Extends
- Paged<RequestOptionsWithRuleset<TIModel, TRulesetVariable>>
Properties
Name | Type | Description | |
---|---|---|---|
displayType | string | undefined | Content display type. | |
keys | TKeySet | Input keys for getting the content. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
imodel Inherited | TIModel | Paged | iModel to request data from |
locale Inherited | string | undefined | Paged | Optional locale to use when formatting / localizing data |
paging Inherited | PageOptions | undefined | Paged | Optional paging parameters |
rulesetOrId Inherited | string | Ruleset | Paged | Ruleset or id of the ruleset to use when requesting data |
rulesetVariables Inherited | TRulesetVariable[] | undefined | Paged | Ruleset variables to use when requesting data |
unitSystem Inherited | UnitSystemKey | undefined | Paged | Unit system to use when formatting property values with units. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.