StructPropertiesFieldJSON<TClassInfoJSON> Interface
Data structure for a StructPropertiesField serialized to JSON.
Extends
- PropertiesFieldJSON<TClassInfoJSON>
Properties
Name | Type | Description | |
---|---|---|---|
memberFields | PropertiesFieldJSON<TClassInfoJSON>[] |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
category Inherited | string | PropertiesFieldJSON<TClassInfoJSON> | |
editor Inherited | EditorDescription | undefined | PropertiesFieldJSON<TClassInfoJSON> | |
extendedData Inherited | { T } | undefined | PropertiesFieldJSON<TClassInfoJSON> | |
isReadonly Inherited | boolean | PropertiesFieldJSON<TClassInfoJSON> | |
label Inherited | string | PropertiesFieldJSON<TClassInfoJSON> | |
name Inherited | string | PropertiesFieldJSON<TClassInfoJSON> | |
priority Inherited | number | PropertiesFieldJSON<TClassInfoJSON> | |
properties Inherited | PropertyJSON<TClassInfoJSON>[] | PropertiesFieldJSON<TClassInfoJSON> | |
renderer Inherited | RendererDescription | undefined | PropertiesFieldJSON<TClassInfoJSON> | |
type Inherited | TypeDescription | PropertiesFieldJSON<TClassInfoJSON> |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.