getToolTip Method

Invoked before the locate tooltip is displayed to retrieve the information about the located element. Allows the tool to override the toolTip.

getToolTip(hit: HitDetail): Promise<string | HTMLElement>

@returns A Promise for the HTMLElement or string to describe the hit.

@note If you override this method, you may decide whether to call your superclass' implementation or not (it is not required).

Parameter Type Description
hit HitDetail The HitDetail whose info is needed.

Returns - Promise<string | HTMLElement>

A Promise for the HTMLElement or string to describe the hit.

Defined in

Last Updated: 14 November, 2024