LinearlyLocatedSingleFromTo Interface
Interface to optionally be implemented by Elements inherently Linearly-Located whose linear-locations are always a single from-to-position. It also provides convenient APIs for callers to reach Linear-Referencing data stored on aspects. Classes implementing this interface should make use of the services provided by LinearlyLocated.
Extends
Methods
Name | Description | |
---|---|---|
getFromToLocation(): undefined | LinearlyReferencedFromToLocation | ||
updateFromToLocation(linearLocation: LinearlyReferencedFromToLocationProps, aspectId?: string): void |
Inherited methods
Name | Inherited from | Description |
---|---|---|
getLinearElementId(): undefined | string Inherited | LinearlyLocatedBase |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.