getAtLocation MethodStatic
Query for the single LinearlyReferenced AtLocation aspect owned by the specified LinearlyLocated Element. If more than one aspect is expected, use getAtLocations instead.
getAtLocation(iModel: IModelDb, linearlyLocatedElementId: string): undefined | LinearlyReferencedAtLocation
@returns Returns an LinearlyReferencedAtLocation or undefined is none is found.
@throws IModelError
Parameter | Type | Description |
---|---|---|
iModel | IModelDb | The iModel to query from. |
linearlyLocatedElementId | string | The id of the LinearlyLocated Element to query about. |
Returns - undefined | LinearlyReferencedAtLocation
Returns an LinearlyReferencedAtLocation or undefined is none is found.
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.