IModelTransformOptions Interface
Options provided to the IModelTransformer constructor.
@note if adding an option, you must explicitly add its serialization to saveStateToFile!
Properties
Name | Type | Description | |
---|---|---|---|
argsForProcessChanges | ProcessChangesOptions | undefined | Arguments to use for the processing of changes. | |
branchRelationshipDataBehavior | "reject" | "unsafe-migrate" | Do not error out if a scoping ESA | |
cloneUsingBinaryGeometry | boolean | undefined | Flag that indicates whether or not the transformation process should clone using binary geometry. | |
danglingReferencesBehavior | "reject" | "ignore" | The behavior to use when an element reference (id) is found stored as a reference on an element in the source, | |
forceExternalSourceAspectProvenance | boolean | undefined | force the insertion of external source aspects to provide provenance, even if there are federation guids | |
includeSourceProvenance | boolean | undefined | Set to true to clone existing source provenance into the target. |
|
loadSourceGeometry | boolean | undefined | Flag that indicates whether or not the transformation process needs to consider the source geometry before cloning/transforming. | |
noDetachChangeCache | boolean | undefined | Do not detach the change cache that we build. | |
noProvenance | boolean | undefined | Set to true if IModelTransformer should not record its provenance. |
|
optimizeGeometry | OptimizeGeometryOptions | undefined | If defined, options to be supplied to optimizeGeometry by process | |
preserveElementIdsForFiltering | boolean | undefined | Flag that indicates that ids should be preserved while copying elements to the target | |
skipPropagateChangesToRootElements | boolean | undefined | Skip propagating changes made to the root subject, dictionaryModel and IModelImporter._realityDataSourceLinkPartitionStaticId (0xe) | |
targetScopeElementId | string | undefined | The Id of the Element in the target iModel that represents the source repository as a whole and scopes its ExternalSourceAspect instances. | |
wasSourceIModelCopiedToTarget | boolean | undefined | Flag that indicates that the target iModel was created by copying the source iModel. |
Defined in
Last Updated: 06 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.