detectElementDeletes Method

Deprecated  in 1.x. Do not use this. // FIXME: how to better explain this?

This method is only called during process when argsForProcessChanges is undefined and the option forceExternalSourceAspectProvenance is enabled. It is not necessary when calling process with argsForProcessChanges defined, since changeset information is sufficient.

Detect Element deletes using ExternalSourceAspects in the target iModel and a brute force comparison against Elements in the source iModel.

detectElementDeletes(): Promise<void>

@note you do not need to call this directly unless processing a subset of an iModel.

@throws IModelError If the required provenance information is not available to detect deletes.

Returns - Promise

Defined in

Last Updated: 06 November, 2024