TimelineDataProvider Interface
Interface for a timeline data provider class
Methods
Name | Description | |
---|---|---|
getSettings(): PlaybackSettings | ||
loadTimelineData(): Promise<boolean> | Async call to load milestone and settings data | |
updateSettings(settings: PlaybackSettings): void | Called to save the playback settings |
Properties
Name | Type | Description | |
---|---|---|---|
animationFraction | number | undefined | Current animation fraction from 0.0 to 1.0 | |
duration | number | Called to get the duration of the Playback. | |
end | Date | undefined | End date for entire timeline | |
id | string | uniqueId of provider | |
initialDuration | number | Called to get the initial scrubber location. | |
loop | boolean | If true the playback will continuously loop. | |
onAnimationFractionChanged | AnimationFractionChangeHandler | undefined | Called when the an internal process has defined the playback settings and the UI needs to be updated | |
onPlaybackSettingChanged | PlaybackSettingsChangeHandler | undefined | Called when an internal process has defined the playback settings and the UI needs to be updated | |
start | Date | undefined | Starting date for entire timeline | |
supportsTimelineAnimation | boolean | returns true if the provider has timeline animation data available | |
viewId | string | view id when viewport is initially assigned | |
viewport | ScreenViewport | undefined | viewport to show animation |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.