setActiveMarker Method
Sets the currently active marker. This function is invoked when the user clicks on a marker, but may also be called manually to produce the same result. Changing the active marker first deactivates the currently active marker, if any; then activates the specified marker, if supplied. Returns false if marker activation fails.
setActiveMarker(marker: SectionMarker): Promise<boolean>
@see - activeMarker to obtain the currently active section marker.
- activateMarker to control what happens when a marker is activated.
- deactivateMarker to control what happens when a marker is deactivated.
Parameter | Type | Description |
---|---|---|
marker | SectionMarker |
Returns - Promise
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.