alignToSpatialView Method
Aligns the view to match the frustum of the spatial view associated with the specified marker.
alignToSpatialView(marker: SectionMarker): Promise<boolean>
@returns false if the frustum could not be applied, e.g. because the spatial view could not be loaded or the viewport is viewing a 2d model.
@see - alignView to align to the section plane, which may differ.
- toggleSection to also apply the clip volume.
Parameter | Type | Description |
---|---|---|
marker | SectionMarker | The marker whose spatial view's frustum should be applied. |
Returns - Promise
false if the frustum could not be applied, e.g. because the spatial view could not be loaded or the viewport is viewing a 2d model.
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.