toggleSection Method
Toggles the specified section marker. Enabling the section applies the frustum and clip volume of the marker's spatial view to the viewport, and displays the 2d section graphics and sheet annotations. Disabling the section disables the clip volume and 2d graphics.
toggleSection(marker: SectionMarker, enable: boolean): Promise<boolean>
@see - toggleClipVolume to toggle only the clip volume.
- toggleAttachment to toggle only the attachment graphics.
Parameter | Type | Description |
---|---|---|
marker | SectionMarker | |
enable | boolean |
Returns - Promise
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.