SourceAspectIdTool Class
Base class for a tool that can convert between source aspect Ids and element Ids. A "source aspect Id" is a string that identifies an object (such as an element) in the source document from which the iModel originated. For example, if the iModel was produced by the MicroStation bridge, the source aspect Id is usually a V8 element Id.
Extends
Extended by
Methods
Name | Description | |
---|---|---|
constructor(..._args: any[]): SourceAspectIdTool | ||
getECSql(queryId: string): string Protected Abstract | ||
parseAndRun(...keyinArgs: string[]): Promise<boolean> | Run this instance of a tool using a series of string arguments. | |
run(idToQuery?: string, copyToClipboard?: boolean): Promise<boolean> | Run this instance of a Tool. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
register(namespace?: string): void Static Inherited | Tool | Register this Tool class with the ToolRegistry. |
Properties
Name | Type | Description | |
---|---|---|---|
maxArgs Accessor Static ReadOnly | number | The maximum number of arguments allowed by parseAndRun, or undefined if there is no maximum. | |
minArgs Accessor Static ReadOnly | number | The minimum number of arguments allowed by parseAndRun. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
description Accessor Inherited ReadOnly | string | Tool | Get the localized description string from this Tool's class |
description Accessor Static Inherited ReadOnly | string | Tool | Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, Tool.flyover is returned. |
englishKeyin Accessor Static Inherited ReadOnly | string | Tool | Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
flyover Accessor Inherited ReadOnly | string | Tool | Get the localized flyover string from this Tool's class |
flyover Accessor Static Inherited ReadOnly | string | Tool | Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, Tool.keyin is returned. |
hidden Static Inherited | boolean | Tool | If true, this Tool will not appear in the list from ToolRegistry.getToolList. |
iconSpec Accessor Inherited ReadOnly | string | Tool | Get the iconSpec from this Tool's class. |
iconSpec Static Inherited | string | Tool | The icon for this Tool. |
keyin Accessor Inherited ReadOnly | string | Tool | Get the localized keyin string from this Tool's class |
keyin Accessor Static Inherited ReadOnly | string | Tool | Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
namespace Static Inherited | string | Tool | The namespace that provides localized strings for this Tool. |
toolId Accessor Inherited ReadOnly | string | Tool | Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize the keyin, description, etc. from the current locale. |
toolId Static Inherited | string | Tool | The unique string that identifies this tool. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.