ElectronRendererAuthorization Class
Object to be set as IModelApp.authorizationClient
for the frontend of ElectronApps.
Since Electron Apps use the backend for all authorization, this class sends signIn/signOut requests to the backend
and then gets the access token from the backend.
Implements
Methods
Name | Description | |
---|---|---|
constructor(config: ElectronRendererAuthorizationConfiguration): ElectronRendererAuthorization | Constructor for ElectronRendererAuthorization. | |
getAccessToken(): Promise<string> | Returns a promise that resolves to the AccessToken if signed in. | |
signIn(): Promise<void> | Called to start the sign-in process. | |
signInSilent(): Promise<void> | Called to start the silent sign-in process. | |
signOut(): Promise<void> | Called to start the sign-out process. |
Properties
Name | Type | Description | |
---|---|---|---|
hasSignedIn Accessor ReadOnly | boolean | ||
isAuthorized Accessor ReadOnly | boolean | ||
onAccessTokenChanged Readonly | BeEvent<(token: string) => void> |
Defined in
- renderer/Client.ts Line 81
Last Updated: 06 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.