ElectronMainAuthorizationConfiguration Interface
Client configuration to generate OIDC/OAuth tokens for native applications
Properties
Name | Type | Description | |
---|---|---|---|
authenticationOptions Readonly | AuthenticationOptions | undefined | Additional options to use for every OIDC authentication request made by ElectronMainAuthorization. | |
clientId Readonly | string | Client application's identifier as registered with the OIDC/OAuth2 provider. | |
expiryBuffer Readonly | number | undefined | Time in seconds that's used as a buffer to check the token for validity/expiry. | |
ipcSocket Readonly | IpcSocketBackend | undefined | Optional custom implementation of IpcSocketBackend to use for IPC communication with the Frontend counterpart of | |
issuerUrl Readonly | string | undefined | The OAuth token issuer URL. | |
redirectUris Readonly | string[] | List of redirect URIs available for use in the OAuth authorization flow. | |
scopes Readonly | string | List of space separated scopes to request access to various resources. |
Defined in
- main/Client.ts Line 74
Last Updated: 06 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.