IpcSocketBackend Interface
Interface for the backend (Node.js) side of a socket connection. Backends provide the implementation of methods that are invoked from the frontend.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
handle | (channel: string, handler: (...args: any[]) => Promise<any>) => RemoveFunction | Establish a backend implementation of an Ipc interface for a channel. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
addListener | (channel: string, listener: IpcListener) => RemoveFunction | IpcSocket | Establish a handler to receive messages for a channel through a socket. |
removeListener | (channel: string, listener: IpcListener) => void | IpcSocket | Remove a previously registered listener |
send | (channel: string, ...data: any[]) => void | IpcSocket | Send a message over the socket. |
Defined in
- core/common/src/ipc/IpcSocket.ts Line 89
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.