Phenomenon Class

Extends

Methods

Name Description
constructor(schema: Schema, name: string): Phenomenon    
fromJSON(phenomenonProps: PhenomenonProps): Promise<void>    
fromJSONSync(phenomenonProps: PhenomenonProps): void    
setDefinition(definition: string): Promise<void> Protected    
toJSON(standalone: booleanfalse, includeSchemaVersion: booleanfalse): PhenomenonProps Save this Phenomenon's properties to an object for serializing to JSON.  

Inherited methods

Name Inherited from Description
equalByKey(thisSchemaItem: SchemaItem, thatSchemaItemOrKey?: SchemaItemKey | SchemaItem): boolean Static Inherited SchemaItem Indicates if the two SchemaItem objects are equal by comparing their respective key properties.
parseFullName(fullName: string): [string, string] Static Inherited SchemaItem Parses the given full name, {schemaName}.{schemaItemName} or {schemaName}:{schemaItemName}, into two separate strings.

Properties

Name Type Description
_definition Protected string    
definition Accessor ReadOnly string    
schemaItemType Readonly Phenomenon    

Inherited properties

Name Type Inherited from Description
_description Protected Inherited string | undefined SchemaItem  
_key Protected Inherited SchemaItemKey SchemaItem  
_label Protected Inherited string | undefined SchemaItem  
description Accessor Inherited ReadOnly undefined | string SchemaItem  
fullName Accessor Inherited ReadOnly string SchemaItem  
key Accessor Inherited ReadOnly SchemaItemKey SchemaItem  
label Accessor Inherited ReadOnly undefined | string SchemaItem  
name Accessor Inherited ReadOnly string SchemaItem  
schema Readonly Inherited Schema SchemaItem  

Defined in

Last Updated: 14 November, 2024