getProperties Method
Iterates all properties, including the ones merged from base classes and mixins. To obtain only local properties, use the 'properties' field. Since this is an expensive operation, results will be cached after first call.
getProperties(resetCache: booleanfalse): Promise<Property[]>
Parameter | Type | Description |
---|---|---|
resetCache | boolean | if true, any previously cached results will be dropped and cache will be rebuilt |
Returns - Promise<Property[]>
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.