getSchemaSync Method
Attempts to obtain a schema from this context that matches the specified criteria. Will return undefined if the schema is partially loaded. Use getSchema to await until the schema is completely loaded.
getSchemaSync<T extends Schema>(schemaKey: SchemaKey, matchType: SchemaMatchTypeSchemaMatchType.Latest): undefined | T
@returns the schema matching the input criteria, or undefined
if no such schema could be located.
Parameter | Type | Description |
---|---|---|
schemaKey | SchemaKey | Identifies the schema to obtain. |
matchType | SchemaMatchType | Criteria by which to identify potentially matching schemas. |
Returns - undefined | T
the schema matching the input criteria, or undefined
if no such schema could be located.
Defined in
- ecschema-metadata/src/Context.ts Line 352
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.