getSchema Method
Attempts to obtain a schema from this context that matches the specified criteria.
getSchema<T extends Schema>(schemaKey: Readonly<SchemaKey>, matchType: SchemaMatchTypeSchemaMatchType.Latest): Promise<undefined | T>
@returns the schema matching the input criteria, or undefined
if no such schema could be located.
Parameter | Type | Description |
---|---|---|
schemaKey | Readonly<SchemaKey> | Identifies the schema to obtain. |
matchType | SchemaMatchType | Criteria by which to identify potentially matching schemas. |
Returns - Promise<undefined | T>
the schema matching the input criteria, or undefined
if no such schema could be located.
Defined in
- ecschema-metadata/src/Context.ts Line 319
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.