getSchemaInfo Method
Gets the schema info which matches the provided SchemaKey. The schema info may be returned before the schema is fully loaded. The fully loaded schema can be gotten later from the context using getSchema.
getSchemaInfo(schemaKey: Readonly<SchemaKey>, matchType: SchemaMatchType): Promise<undefined | SchemaInfo>
Parameter | Type | Description |
---|---|---|
schemaKey | Readonly<SchemaKey> | The SchemaKey describing the schema to get from the cache. |
matchType | SchemaMatchType | The match type to use when locating the schema |
Returns - Promise<undefined | SchemaInfo>
Defined in
- ecschema-metadata/src/Context.ts Line 336
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.