constructor Method
Initializes a new ClassDiagnostic.
ClassDiagnostic<ARGS extends any[]>(ecClass: AnyClass, messageArgs: ARGS, category: DiagnosticCategoryDiagnosticCategory.Error): ClassDiagnostic<ARGS>
Parameter | Type | Description |
---|---|---|
ecClass | AnyClass | The class to associate with the diagnostic. |
ARGS | The arguments used when formatting the diagnostic message. | |
category | DiagnosticCategory | The DiagnosticCategory to associate with the diagnostic, Error by default. |
Returns - ClassDiagnostic<ARGS>
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.