CustomFormatProps Interface

This interface is used when supporting Custom Formatters that need more than the standard set of properties.

Extends

Properties

Name Type Description
custom Readonly any    

Inherited properties

Name Type Inherited from Description
allowMathematicOperations Readonly Inherited boolean | undefined FormatProps  
azimuthBase Readonly Inherited number | undefined FormatProps The base value for azimuth, specified from east counter-clockwise.
azimuthBaseUnit Readonly Inherited string | undefined FormatProps The name of the unit for the azimuth base value.
azimuthCounterClockwise Readonly Inherited boolean | undefined FormatProps If set to true, azimuth values are returned counter-clockwise from the base.
composite Readonly Inherited { includeZero?: boolean, spacer?: string, units: { label?: string, name: string }[] } | undefined FormatProps  
decimalSeparator Readonly Inherited string | undefined FormatProps  
formatTraits Readonly Inherited string | string[] FormatProps  
minWidth Readonly Inherited number | undefined FormatProps  
precision Readonly Inherited number | undefined FormatProps  
ratioType Readonly Inherited string | undefined FormatProps conditionally required.
revolutionUnit Readonly Inherited string | undefined FormatProps The name of the unit that represents a revolution/perigon.
roundFactor Readonly Inherited number | undefined FormatProps  
scientificType Readonly Inherited string | undefined FormatProps conditionally required.
showSignOption Readonly Inherited string | undefined FormatProps  
stationOffsetSize Readonly Inherited number | undefined FormatProps conditionally required.
stationSeparator Readonly Inherited string | undefined FormatProps  
thousandSeparator Readonly Inherited string | undefined FormatProps  
type Readonly Inherited string FormatProps  
uomSeparator Readonly Inherited string | undefined FormatProps  

Defined in

Last Updated: 14 November, 2024