FormatProps Interface
This interface defines the persistence format for describing the formatting of quantity values.
Properties
Name | Type | Description | |
---|---|---|---|
allowMathematicOperations Readonly | boolean | undefined | ||
azimuthBase Readonly | number | undefined | The base value for azimuth, specified from east counter-clockwise. | |
azimuthBaseUnit Readonly | string | undefined | The name of the unit for the azimuth base value. | |
azimuthCounterClockwise Readonly | boolean | undefined | If set to true, azimuth values are returned counter-clockwise from the base. | |
composite Readonly | { includeZero?: boolean, spacer?: string, units: { label?: string, name: string }[] } | undefined | ||
decimalSeparator Readonly | string | undefined | ||
formatTraits Readonly | string | string[] | ||
minWidth Readonly | number | undefined | ||
precision Readonly | number | undefined | ||
ratioType Readonly | string | undefined | conditionally required. | |
revolutionUnit Readonly | string | undefined | The name of the unit that represents a revolution/perigon. | |
roundFactor Readonly | number | undefined | ||
scientificType Readonly | string | undefined | conditionally required. | |
showSignOption Readonly | string | undefined | ||
stationOffsetSize Readonly | number | undefined | conditionally required. | |
stationSeparator Readonly | string | undefined | ||
thousandSeparator Readonly | string | undefined | ||
type Readonly | string | ||
uomSeparator Readonly | string | undefined |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.