CloneOptions Interface
CloneOptions that define modifications that can be made during the cloning of a Format.
Properties
Name | Type | Description | |
---|---|---|---|
precision | DecimalPrecision | FractionalPrecision | allows precision to be set, this will throw if value is not valid for FormatType | |
primaryUnit | CloneUnit | undefined | allows primary unit and label to be specified | |
showOnlyPrimaryUnit | boolean | undefined | allows composite formats to be converted to only show primary unit | |
traits | FormatTraits | undefined | allow format traits to be set | |
type | FormatType | undefined | allows new FormatType to be specified |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.