BasicUnit Class
This class provides basic implementation of UnitProps interface.
Implements
Methods
Name | Description | |
---|---|---|
constructor(name: string, label: string, phenomenon: string, system?: string): BasicUnit |
Properties
Name | Type | Description | |
---|---|---|---|
isValid | boolean | This is set to true if the Unit is known by the UnitsProvider. | |
label | string | Default label for unit. | |
name | string | Unique name for unit. | |
phenomenon | string | Unique name of unit phenomenon. | |
system | string | Unique system name. |
Defined in
- quantity/src/Unit.ts Line 14
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.