BadUnit Class
This class is a convenience class that can be returned when a valid Unit cannot be determined.
Implements
Methods
Name | Description | |
---|---|---|
constructor(): BadUnit |
Properties
Name | Type | Description | |
---|---|---|---|
isValid | boolean | This is set to true if the Unit is known by the UnitsProvider. | |
label | string | Default label for unit. | |
name | string | Unique name for unit. | |
phenomenon | string | Unique name of unit phenomenon. | |
system | string | Unique system name. |
Defined in
- quantity/src/Unit.ts Line 36
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.