createInFrame MethodStatic
Create a new TorusPipe
createInFrame(frame: Transform, majorRadius: number, minorRadius: number, sweep: Angle, capped: boolean): undefined | TorusPipe
Parameter | Type | Description |
---|---|---|
frame | Transform | local to world transformation. For best results, the matrix part should be a pure rotation. |
majorRadius | number | major hoop radius |
minorRadius | number | minor hoop radius |
sweep | Angle | sweep angle for major circle, with positive sweep from x axis towards y axis. |
capped | boolean | true for circular caps |
Returns - undefined | TorusPipe
Defined in
- solid/TorusPipe.ts Line 96
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.