prepareBSplineSurfaceData MethodStatic
Prepare imported B-spline surface data for eventual conversion to BSplineSurface3d | BSplineSurface3dH:
- Opens legacy "fake" periodic data by expanding knots
- Opens true periodic data by expanding poles and weights
prepareBSplineSurfaceData(data: SerializationHelpers.BSplineSurfaceData, options?: SerializationHelpers.BSplineDataOptions): boolean
@returns whether data was successfully prepared
Parameter | Type | Description |
---|---|---|
data | SerializationHelpers.BSplineSurfaceData | updated in place. If poles/weights/knots are updated, their respective arrays are reallocated. |
options | SerializationHelpers.BSplineDataOptions | output specifications |
Returns - boolean
whether data was successfully prepared
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.