SerializationHelpers.BSplineSurfaceData Interface
Interface for B-spline surface data.
Properties
Name | Type | Description | |
---|---|---|---|
dim | number | The number of coordinates per pole. | |
poles | Float64Array | number[][][] | Control points, aka poles in row-major order. | |
uParams | SerializationHelpers.BSplineParams | Knots and other B-spline data with respect to the surface u parameter. | |
vParams | SerializationHelpers.BSplineParams | Knots and other B-spline data with respect to the surface v parameter. | |
weights | Float64Array | number[][] | Weights for a rational surface that is specified by parallel arrays of poles and weights. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.