prepareBSplineSurfaceData MethodStatic
Prepare data from a B-spline surface for export.
- adds classic extraneous knot at start and end of knot vectors
- re-closes periodic data based on BSplineWrapMode
prepareBSplineSurfaceData(data: SerializationHelpers.BSplineSurfaceData, options?: SerializationHelpers.BSplineDataOptions): boolean
@returns whether data was successfully prepared
Parameter | Type | Description |
---|---|---|
data | SerializationHelpers.BSplineSurfaceData | updated in place. If poles/weights/knots are updated, their respective arrays are reallocated. |
options | SerializationHelpers.BSplineDataOptions | output specifications |
Returns - boolean
whether data was successfully prepared
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.