DeepCompare Class
Utilities to compare json objects by searching through their properties.
Methods
Name | Description | |
---|---|---|
constructor(numberRelTol: number1.0e-12): DeepCompare | Construct comparison object with relative tolerance. | |
compare(a: any, b: any, tolerance?: number): boolean | Main entry for comparing deep json objects. | |
compareNumber(a: number, b: number): boolean | Test if a and b are within tolerance. |
Properties
Defined in
- serialization/DeepCompare.ts Line 14
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.