searchForClosestPoint Method
Search the range tree for closest facet(s) to spacePoint.
searchForClosestPoint(spacePoint: Point3d, maxDist?: number, searchFacetInterior: booleanfalse): undefined | FacetLocationDetail | FacetLocationDetail[]
@returns closest point detail(s) with detail.a set to the distance from spacePoint to detail.point
Parameter | Type | Description |
---|---|---|
spacePoint | Point3d | point to test |
maxDist | number | collect points at no more than this distance from spacePoint. If undefined, return only the closest point. |
searchFacetInterior | boolean | whether to include facet interiors in search. Default is false: just consider facet boundaries. |
Returns - undefined | FacetLocationDetail | FacetLocationDetail[]
closest point detail(s) with detail.a set to the distance from spacePoint to detail.point
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.