FacetLocationDetail Interface
Carries data about a point in the plane of a facet of a mesh.
@see intersectRay3d
Implemented by
Methods
Name | Description | |
---|---|---|
clone(): FacetLocationDetail | Clone the instance | |
copyContentsFrom(other: FacetLocationDetail): void | Set the instance contents from the other detail | |
getBarycentricCoordinates(facetVertices?: IndexedXYZCollection, distanceTolerance?: number): undefined | number[] | Get reference to cached barycentric coordinates of the point. | |
getColor(facetColors?: number[], facetVertices?: IndexedXYZCollection, distanceTolerance?: number): undefined | number | Get cached color interpolated from facet data. | |
getNormal(facetNormals?: IndexedXYZCollection, facetVertices?: IndexedXYZCollection, distanceTolerance?: number): undefined | Vector3d | Get reference to cached normal interpolated from facet data. | |
getParam(facetParams?: IndexedXYCollection, facetVertices?: IndexedXYZCollection, distanceTolerance?: number): undefined | Point2d | Get reference to cached uv parameter interpolated from facet data. |
Defined in
- polyface/FacetLocationDetail.ts Line 57
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.