SweepLineStringToFacetsOptions Class
Options carrier for sweeping linework onto meshes.
- The create method initializes all options.
Methods
Name | Description | |
---|---|---|
collectFromThisFacetNormal(facetNormal: Vector3d): boolean | Decide if the instance collector flags accept a facet with the given normal. | |
create(vectorToEye?: Vector3d, sideAngle?: Angle, assembleChains?: boolean, collectOnForwardFacets?: boolean, collectOnSideFacets?: boolean, collectOnRearFacets?: boolean): SweepLineStringToFacetsOptions Static | Create an options structure. |
Properties
Name | Type | Description | |
---|---|---|---|
assembleChains | boolean | Option to assemble lines into chains. | |
collectAll Accessor ReadOnly | boolean | Return true if all outputs are requested. |
|
collectOnForwardFacets | boolean | True to collect edges from facets that face towards the eye. | |
collectOnRearFacets | boolean | True to collect facets that face away from the eye. | |
collectOnSideFacets | boolean | True to collect facets that are "on the side", i.e., their outward vector is perpendicular to vectorToEye. | |
sideAngle | Angle | (Small) angle to use as tolerance for deciding if a facet is "on the side". | |
vectorToEye | Vector3d | Vector towards the eye. |
Defined in
- polyface/PolyfaceQuery.ts Line 65
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.